[Rcpp-devel] V8 crashes on 32bit windows when built with new Rtools

JJ Allaire jj.allaire at gmail.com
Thu Mar 12 22:40:57 CET 2015

I had an issue like this in RcppParallel that was solved by rebuilding
Rcpp from source using the very latest R-devel and Rtools 3.3. Have
you tried that?


On Thu, Mar 12, 2015 at 5:25 PM, Jeroen Ooms <jeroen.ooms at stat.ucla.edu> wrote:
> This is probably not exclusively Rcpp problem, but I could use some
> debugging help from Rcpp experts.
> When building V8 on windows with the new tool chain, the build succeeds and
> the package can be loaded, but when trying to use it on i386, it crashes (it
> works fine on x64). Other packages that link to external c++ libraries (e.g.
> RQuantlib) might suffer from this as well.
> To reproduce, install latest rtools and r-devel on windows and run:
>   install.packages("V8", type = "source")
>   library(V8)
>   ct <- new_context()
> The R.exe process crashes without any error message or crashdump, which
> makes this very difficult to debug. I suspect that the problem is that the
> new Rtools has been built with some different settings resulting in
> incompatible binaries, but I can't find the problem.
> Any suggestions on where to start debugging this?
> _______________________________________________
> Rcpp-devel mailing list
> Rcpp-devel at lists.r-forge.r-project.org
> https://lists.r-forge.r-project.org/cgi-bin/mailman/listinfo/rcpp-devel

More information about the Rcpp-devel mailing list