[Rcpp-devel] V8 crashes on 32bit windows when built with new Rtools

Duncan Murdoch murdoch.duncan at gmail.com
Thu Mar 12 23:49:21 CET 2015

On 12/03/2015 5:51 PM, Jeroen Ooms wrote:
> On Thu, Mar 12, 2015 at 2:40 PM, JJ Allaire <jj.allaire at gmail.com
> <mailto:jj.allaire at gmail.com>> wrote:
>     I had an issue like this in RcppParallel that was solved by rebuilding
>     Rcpp from source using the very latest R-devel and Rtools 3.3. Have
>     you tried that?
> Yes, that doesn't seem to help.
> I have a suspicion now. I have seen this behavior before when linking
> libraries on windows that were built with different threading models.
> Based on gcc -v, the old rtools (and hence my v8 static libs) use win32
> threading, whereas the new rtools has been built with
> --enable-threads=posix.

The scripts are on CRAN, if you want to try modifying them.  However, if
the scripts aren't satisfactory very soon, I'll just go back to the
previous Rtools.


More information about the Rcpp-devel mailing list