[Rcpp-devel] RcppArmadillo and the version of Rcpp

Greg Distiller greg.distiller at uct.ac.za
Thu Oct 24 15:06:30 CEST 2013

I am new to the list and new to Cpp and Rcpp. I have run into a problem when trying to load the RcppArmadillo package. Apparently I need at least version 0.10.5 of Rcpp and I have version 0.10.4. If I try and update this from within RStudio it doesn't offer 0.10.5 as an option, and when I tried to install the 0.10.5 version from CRAN the Rcpp package stopped working altogether. When I tried to load the 0.10.5 package I get the following error message:

Error in eval(expr, envir, enclos) :
  could not find function ".getNamespace"

I am using R version 2.15.1 but the Rcpp 0.10.5 info says that it should work on this version. Can anyone please advise me on what is going on and how I can get RcppArmadillo to work?



This e-mail is subject to the UCT ICT policies and e-mail disclaimer published on our website at http://www.uct.ac.za/about/policies/emaildisclaimer/ or obtainable from +27 21 650 9111. This e-mail is intended only for the person(s) to whom it is addressed. If the e-mail has reached you in error, please notify the author. If you are not the intended recipient of the e-mail you may not use, disclose, copy, redirect or print the content. If this e-mail is not related to the business of UCT it is sent by the sender in the sender's individual capacity.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.r-forge.r-project.org/pipermail/rcpp-devel/attachments/20131024/eb5fb306/attachment.html>

More information about the Rcpp-devel mailing list