[Rcpp-devel] linking fail when building examples of my local copy of Rcpp gallery (windows)

Hadley Wickham h.wickham at gmail.com
Wed Apr 17 22:33:58 CEST 2013

> Dear Hadley, Dirk removed 3/4 of my original message :) I just added it now after your email so that our discussion inherit from the past.

That was me - I don't think it's relevant to your problem.

> - When I run make from MinGW terminal in the src folder of the git web site this fails (the most important part of my log is reproduced in my initial message, I admit my error might come from my use of MinGW). Also I add to change the relative path in the makefile to reach this point (see my initial email)
> - When I run the knit function of Dirk (that of the knit.sh script) in R this produces a md file correctly.
> This is the reason why I said this has to do with my Path ...

> PS: I'm using RStudio, I hardly can use anything else now that I'm used to it, except for cpp code completion/syntax correction where StatET-Ecplise still is quite good héhé.  But with StatET-Eclipse I manage to do code correction/completion but not to compile my Rcpp package might it be the same problem ? that RStudio has some extra power it does not share :) ?

Yes - the fact that you're on windows and using Rstudio is critical
because it does a lot of work to find out where rtools was installed
and set your path correctly. Rcpp does a little bit of work to try and
figure it out, but not as exhaustively as Rstudio.

The easiest way to resolve the difference would to be run make from
inside of Rstudio: system("make")


Chief Scientist, RStudio

More information about the Rcpp-devel mailing list