[Rcpp-devel] Rcpp 0.10.1 and RcppEigen

Kasper Daniel Hansen kasperdanielhansen at gmail.com
Tue Nov 27 22:54:45 CET 2012

Rcpp 0.10.1 was released yesterday (?).  Installing it breaks
RcppEigen and RcppArmadillo (same error message).  Reinstalling the
packages fixes RcppArmadillo, but not RcppEigen.

The error I get from compiling RcppEigen (version 0.3.1) is

  instantiated from ‘T Rcpp::internal::as(SEXPREC*,
Rcpp::traits::r_type_generic_tag) [with T =
Eigen::Map<Eigen::Matrix<double, -0x00000000000000001, 1, 0,
-0x00000000000000001, 1>, 0, Eigen::Stride<0, 0> >]’
  instantiated from ‘T Rcpp::as(SEXPREC*) [with T =
Eigen::Map<Eigen::Matrix<double, -0x00000000000000001, 1, 0,
-0x00000000000000001, 1>, 0, Eigen::Stride<0, 0> >]’
fastLm.cpp:208:   instantiated from here
../inst/include/RcppEigenWrap.h:169: error: no matching function for
call to ‘r_vector_start(SEXPREC*&)’
make: *** [fastLm.o] Error 1
ERROR: compilation failed for package ‘RcppEigen’

This translates to the following error when I load the already
installed version of RcppEigen:

> library(RcppEigen)
Loading required package: Rcpp
Loading required package: Matrix
Loading required package: lattice
Error in dyn.load(file, DLLpath = DLLpath, ...) :
  unable to load shared object
undefined symbol:
Error: package or namespace load failed for ‘RcppEigen’

I got the same error for RcppArmadillo ( when doing
library(RcppArmadillo), but this was fixed re-installing the package
(unlike RcppEigen).

This may be something you are aware of.  I am mostly using RcppEigen
through a chain of dependencies.

I am on a fairly old system, with GCC 4.2.1 under Redhat Enterprise
Linux version 4.  This is for our cluster, so it is not easy for me to


More information about the Rcpp-devel mailing list