[Rcpp-devel] R vectorisation vs. C++ vectorisation
darren at dcook.org
Thu Nov 22 01:55:24 CET 2012
> | > I believe that such a function is normally called "clamp".
> | I'd not heard that before; is that the mathematical word for it? (clip
> | is terminology from graphics programming, where a clipping rectangle is
> | another word for a window or viewport)
Thanks Dirk. Compare with
http://en.wikipedia.org/wiki/Clipping_%28computer_graphics%29 and it
seems my use of the word clip was a bit sloppy.
So, yes, clamp() does seem like the more suitable name.
Darren Cook, Software Researcher/Developer
http://dcook.org/work/ (About me and my work)
http://dcook.org/blogs.html (My blogs and articles)
More information about the Rcpp-devel