[Rcpp-devel] Configuring GSL headers for inline

Dirk Eddelbuettel edd at debian.org
Sat Jul 7 03:35:42 CEST 2012

On 7 July 2012 at 00:31, Silkworth,David J. wrote:
| After the glow of success with configuring GSL headers and libraries for compilation in Windows, I have run into a problem duplicating this success using inline for compiling.
| I have attempted the inline example directly from the RcppGSL Vignette.  It is clear that the includes are not being accessed.  Here is the tell tale error message:
| C:/R/R-2.13.1/library/RcppGSL/include/RcppGSLForward.h:26:29: fatal error: gsl/gsl_vector.h: No such file or directory
| compilation terminated.
| I've seen this before.  This was the same error I got compiling the RcppGSLExample package before I created a Windows environment variable LIB_GSL=C:/GnuWin32  (remember the reversed slash direction).
| Alas, it seems that that variable was being read by the Makevars.win script included in the RcppGSLExample\src folder.
| Unfortunately, I still don't know how to direct gcc to these header files while using inline.

The Rcpp-FAQ vignette has a worked example on how to specify a plugin which
should apply to this case, see question 3.6 (or possibly 3.7 if you need just
a single setting).


Dirk Eddelbuettel | edd at debian.org | http://dirk.eddelbuettel.com  

More information about the Rcpp-devel mailing list