[Rcpp-devel] RInside 0.2.3 on Windows?

Carl Vincent carl.vincent38 at gmail.com
Tue Dec 14 15:03:41 CET 2010

I was interested in calling some R functions from a C++ program running on
Windows (for a study project) ,
that's why I've tried to use RInside on the "overly complicated 'hello,
world' program", without achieving...

I've tried a lot of different things, even modified the
I've put hard links for
doesn't like :
*echo 'Rcpp:::CxxFlags()' | $(R_HOME)/bin/R --vanilla --slave *)

It looks like :
RCPPINCL :=  -I"C:/Users/Carl/Documents/R/win-library/2.12/Rcpp/include"
RCPPLIBS :=  -LC:/Users/Carl/Documents/R/win-library/2.12/Rcpp/lib/i386
-LC:/Users/Carl/Documents/R/win-library/2.12/RInside/lib/i386/ -llibRInside

When i try* 'make -f Makefile.win*', I get an error :
cannot find -llibRcpp*

So i've looked inside the package, I've seen that, in the folder 'lib\i386',
there is a *libRInside.dll* (with a *libRInside.a*) in RInside but only a *
libRcpp.a* in Rcpp .I've seen that  It's maybe the problem... (i don't know
a lot on the subject...)

I've tried to use the *Rcpp.dll* in 'libs\i386'  instead. (I don't
understand the difference between "lib" and "libs")
The *'make -f Makefile.win*' ends without errors but when i execute the .exe
i get an error : "Rcpp.dll missing"

Afterwards, i saw on forums that new versions of RInside (i have 0.2.3)
doesn't work on Windows.
Is it always true?
If it's true, what version of RInside and Rcpp i need to use instead?

My configuration :
Windows 7 X86 (32 bits)
R 2.12.0
RTools 2.12
RInside 0.2.3
Rcpp 0.8.9

P.S. : Sorry for my English, I'm french!

INSA de Rennes - 4INFO - TDMM
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.r-forge.r-project.org/pipermail/rcpp-devel/attachments/20101214/173f9ee9/attachment.htm>

More information about the Rcpp-devel mailing list