[Traminer-users] installing seqdist2 on a Windows server

Reynolds, Jeremy E reyno113 at purdue.edu
Fri Oct 7 15:21:34 CEST 2016

Thanks, Matthias.  I am still having the same problems, but I guess the issue is on my end.  Hopefully the server administrators will be able to install the updated version of R soon.


From: traminer-users-bounces at lists.r-forge.r-project.org [mailto:traminer-users-bounces at lists.r-forge.r-project.org] On Behalf Of Matthias Studer
Sent: Friday, October 7, 2016 2:17 AM
To: Users questions <traminer-users at lists.r-forge.r-project.org>
Subject: Re: [Traminer-users] installing seqdist2 on a Windows server

Dear Jeremy,

I tried to trigger a new rebuild of the package on the R-Forge server (no version change. This is the only thing that I can do on our side. Hence, if it doesn't work, you'll have to install the latest version on your server.


De : traminer-users-bounces at lists.r-forge.r-project.org<mailto:traminer-users-bounces at lists.r-forge.r-project.org> [mailto:traminer-users-bounces at lists.r-forge.r-project.org] De la part de Reynolds, Jeremy E
Envoyé : jeudi 6 octobre 2016 21:44
À : traminer-users at lists.r-forge.r-project.org<mailto:traminer-users at lists.r-forge.r-project.org>
Objet : [Traminer-users] installing seqdist2 on a Windows server

Dear TraMineR Users,

I am having some difficulty installing seqdist2 on a server that I use to run R.

Installing seqdist2 on my desktop computer is no problem. I am running R 3.3.1 with R Studio 0.99.903 on a windows machine and the command below works fine.

install.packages("seqdist2", repos="http://R-Forge.R-project.org")

Today, however, when I tried to install seqdist2 for the copy of R that is on a Windows 2012 R2 Terminal Server, the results suggested that  the binary copy of seqdist2 at http://R-Forge.R-project.org is older than the source version (see code below).  I find this message surprising because it did not appear when I installed seqdist2 on my desktop.

> install.packages("seqdist2", repos="http://R-Forge.R-project.org")
Installing package into 'C:/Users/reyno113/Documents/R/win-library/3.1'
(as 'lib' is unspecified)

  There is a binary version available (and will be installed) but the source version is later:
         binary source
seqdist2    0.9  0.9-1

trying URL 'http://R-Forge.R-project.org/bin/windows/contrib/3.1/seqdist2_0.9.zip'
Content type 'application/zip' length 168620 bytes (164 KB)
opened URL
downloaded 164 KB

package 'seqdist2' successfully unpacked and MD5 sums checked

The downloaded binary packages are in

Eager to have the newer version of seqdist2, I tried to install from the source file (seqdist2_0.9-1.tar.gz).  Unfortunately, this failed because the version of R installed on the server is too old (see code below).

> install.packages("seqdist2_0.9-1.tar.gz", repos = "http://R-Forge.R-project.org", type="source")

Installing package into 'C:/Users/reyno113/Documents/R/win-library/3.1'

(as 'lib' is unspecified)

Warning in install.packages :

  package 'seqdist2_0.9-1.tar.gz' is not available (for R version 3.1.3)

I have asked my server administrators to update to a newer version of R, but I don't know how long that might take.  Is there a way to use seqdist2 with R version 3.1.3?  Perhaps using this older version of R is the explanation for both problems I encountered?

Any tips would be appreciated.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.r-forge.r-project.org/pipermail/traminer-users/attachments/20161007/d0ddb028/attachment.html>

More information about the Traminer-users mailing list