[Rprotobuf-commits] r581 - in pkg: . R
noreply at r-forge.r-project.org
noreply at r-forge.r-project.org
Thu Dec 19 07:59:56 CET 2013
Author: murray
Date: 2013-12-19 07:59:56 +0100 (Thu, 19 Dec 2013)
New Revision: 581
Modified:
pkg/ChangeLog
pkg/R/00classes.R
pkg/R/completion.R
Log:
Add more missing $ completion methods, and pass ... for
FileDescriptor$name() so it accepts the optional boolean for full
paths as with the other name methods.
Modified: pkg/ChangeLog
===================================================================
--- pkg/ChangeLog 2013-12-19 05:22:02 UTC (rev 580)
+++ pkg/ChangeLog 2013-12-19 06:59:56 UTC (rev 581)
@@ -1,8 +1,11 @@
2013-12-18 Murray Stokely <murray at FreeBSD.org>
* R/completion.R (.DollarNames.EnumValueDescriptor): Add
- $-completion for EnumValueDescriptor class as with other S4
- RProtoBuf classes here.
+ $-completion for EnumValueDescriptor and FileDescriptor classes
+ as with other S4 RProtoBuf classes here.
+ * R/00classes.R (P): Ensure that the FileDescriptor $name() method
+ accepts a boolean for full paths just like the generic name()
+ method.
2013-12-18 Dirk Eddelbuettel <edd at debian.org>
Modified: pkg/R/00classes.R
===================================================================
--- pkg/R/00classes.R 2013-12-19 05:22:02 UTC (rev 580)
+++ pkg/R/00classes.R 2013-12-19 06:59:56 UTC (rev 581)
@@ -288,7 +288,7 @@
"toString" = function(...) toString(x, ...) ,
"asMessage" = function() asMessage(x),
"as.list" = function() as.list(x),
- "name" = function() x at filename,
+ "name" = function(...) name(x, ... ),
"package" = function() x at package,
invisible(NULL)
)
Modified: pkg/R/completion.R
===================================================================
--- pkg/R/completion.R 2013-12-19 05:22:02 UTC (rev 580)
+++ pkg/R/completion.R 2013-12-19 06:59:56 UTC (rev 581)
@@ -31,7 +31,7 @@
names <- c(
.Call( "Descriptor__getMemberNames", x at pointer, PACKAGE = "RProtoBuf" ),
"new(", "read(", "readASCII(", "fileDescriptor()", "name(",
- "toString()", "as.character()",
+ "toString()", "as.character()", "asMessage()",
"containing_type()", "field_count()", "nested_type_count()", "enum_type_count",
"field(", "nested_type(", "enum_type(" )
grep( pattern, names, value = TRUE )
@@ -64,7 +64,7 @@
"fileDescriptor()", "containing_type()",
"is_extension()", "number()", "type(", "cpp_type(", "label(",
"is_repeated()", "is_required()", "is_optional()",
- "message_type()", "enum_type()",
+ "message_type()", "enum_type()", "asMessage()",
"has_default_value()", "default_value(",
)
grep( pattern, names, value = TRUE )
More information about the Rprotobuf-commits
mailing list