[Rcpp-devel] cannot compile qtdensity example on windows

Michele Gubian mm14722 at bristol.ac.uk
Mon May 19 15:08:37 CEST 2014

hi all,

I need to use RInside in Qt on Windows, and I am stuck since more than
a week. In short, I tried to follow these instructions:
where the compilation/linking problems seem to be solved, but for me
the same procedure does not work.

I compile Rcpp and RInside from sources using the toolchain shipped
with Qt (mingw48_32). In order to to that, I change my path by:
set path=C:\PROGRA~1\R\Rtools\bin;C:\Users\Uasolo\faldone\programmi\Qt\Tools\mingw48_32\bin;%PATH%

Then with
qmake qtdensity.pro -r -spec win32-g++
I get makefiles, but
mingw32-make -f Makefile
gives compilation errors. The stderr output from the above command is attached (

I have run out of ideas on what to try next. Please help.


OS and sw packages details follow:

- OS
Windows7 home premium SP1 64-bit

- R
version 3.1.0,
platform       i386-w64-mingw32
arch           i386
os             mingw32
system         i386, mingw32
R was installed from binaries.

Rcpp and RInside installed from sources:
R CMD INSTALL --no-multiarch "C:\\Users/Uasolo/Downloads/Rcpp_0.11.1.tar.gz"
R CMD INSTALL --no-multiarch C:\Users\Uasolo\Downloads\RInside_0.2.11.tar.gz

- Qt:
Qt 5.2.1
Qt Creator 3.0.1 (I think not relevant, since I am trying to compile
qtdensity from command line)
mingw is in: Qt\Tools\mingw48_32
-------------- next part --------------
A non-text attachment was scrubbed...
Name: qtdensity_make.log
Type: application/octet-stream
Size: 9605 bytes
Desc: not available
URL: <http://lists.r-forge.r-project.org/pipermail/rcpp-devel/attachments/20140519/ae948e16/attachment.obj>

More information about the Rcpp-devel mailing list