[Rcpp-devel] Bug: compileAttributes incorrectly handles Rcpp::export-ed functions with multiple arguments

Davor Cubranic cubranic at stat.ubc.ca
Sat Jan 18 00:32:22 CET 2014

On 2014-01-17, at 2:55 PM, Dirk Eddelbuettel wrote:

> You had two mistakes here:
>  i)   after you alter an interface to be used by Rcpp Attributes, you must
>       re-run the compileAttributes() function to update the files.  See the
>       vignette for details.

What do you mean by this? Like I said, I changed the .cpp file and re-run compileAttributes. What I uploaded is the result afterwards.

>       (And if you use RStudio, this is done automagically)

So it is by devtools, on one of the functions I regularly use in my workflow, perhaps "test". If it wasn't, it would be such a pain.

>  ii)  Your C++ function did not work as the 'List z = ...' parameter
>       shadowed an already declared parameter from the function interface.
>       Renaming to zz or z2 works, of course.

I fixed it and rerun compileAttributes. Still the same problem. New version of the package is attached.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: myPackage_1.0-1.tar.gz
Type: application/x-gzip
Size: 2093 bytes
Desc: not available
URL: <http://lists.r-forge.r-project.org/pipermail/rcpp-devel/attachments/20140117/459d1b8f/attachment.bin>
-------------- next part --------------

More information about the Rcpp-devel mailing list