[Rcpp-devel] Segmentation Fault Running RInside Examples

Paul Wiedeking paul.wiedeking at rwth-aachen.de
Tue Feb 11 21:13:01 CET 2014

Dear Sir or Madam,

I am trying to run the rinside_sample0. I use the provided Makefile to 
build it
and that works fine. But when i try to run the example it crashes with a 
segmentation fault.

My configuration is:
- Ubuntu 13.04
- R version 3.0.2 (2013-09-25) -- "Frisbee Sailing"
- Rcpp version 0.11.0
- RInside version 0.2.10

I installed R as described on http://cran.at.r-project.org/:
- added deb http://<my.favorite.cran.mirror>/bin/linux/ubuntu raring/ to 
my apt sources
- sudo apt-get update
- sudo apt-get install r-base
- sudo apt-get install r-base-dev

After that I started R as root and did a
- install.packages(c("Rcpp", "RInside"))

Until here every thing is fine.
But now I tried to make and run one of the RInside examples - without 
A college of mine also tried to build and run the example on his Mac, 
but he gets the same error.
One strange thing is that not even all provided examples can be built 
successfully. Make exits with:

g++ -I/usr/local/lib64/R/include 
-I/usr/local/lib64/R/library/RInside/include -g -O2 -Wall 
-I/usr/local/include rinside_sample9.cpp -L/usr/local/lib64/R/lib -lR 
-Wl,-rpath,/usr/local/lib64/R/lib -L/usr/local/lib64/R/lib -lRblas 
-L/usr/local/lib64/R/lib -lRlapack 
-L/usr/local/lib64/R/library/RInside/lib -lRInside 
-Wl,-rpath,/usr/local/lib64/R/library/RInside/lib -o rinside_sample9
In file included from 
from /usr/local/lib64/R/library/Rcpp/include/RcppCommon.h:128,
from /usr/local/lib64/R/library/Rcpp/include/Rcpp.h:27,
from /usr/local/lib64/R/library/RInside/include/RInsideCommon.h:38,
from /usr/local/lib64/R/library/RInside/include/RInside.h:26,
from rinside_sample9.cpp:7:
In instantiation of ‘void Rcpp::PreserveStorage<CLASS>::set__(SEXP) 
[with CLASS = Rcpp::InternalFunction_Impl<Rcpp::PreserveStorage>; SEXP = 
required from ‘void 
Rcpp::InternalFunction_Impl<StoragePolicy>::set(SEXP) [with 
StoragePolicy = Rcpp::PreserveStorage; SEXP = SEXPREC*]’
required from 
(*)(U0)) [with OUT = const char*; U0 = std::basic_string<char>; 
StoragePolicy = Rcpp::PreserveStorage]’
rinside_sample9.cpp:22:49: required from here
error: ‘class Rcpp::InternalFunction_Impl<Rcpp::PreserveStorage>’ has no 
member named ‘update’
make: *** [rinside_sample9] Error 1

We have also tried to install R from source but there we have the same 

Can you help us?
Did we miss any important step during installation?
If you need more information please let me know.

Yours faithfully
Paul Wiedeking

More information about the Rcpp-devel mailing list