[Rcpp-devel] error using sourceCpp after update

Weldon, Mat m.weldon at lancaster.ac.uk
Thu Oct 31 16:03:09 CET 2013


I have been using Rcpp for a few weeks, and have just tried to install RcppArmadillo, but it failed because apparently there is a dependency on Rcpp version >=0.10.5 (I have 0.10.4 loaded). Just now I have tried to update Rcpp, but each time version 0.10.4 is downloaded from CRAN (I tried a couple of mirrors in the UK).

I did briefly try to download the zip file of 0.10.6 and install it using install.packages("Rcpp",lib="C:/Users/weldonm.LANCS/Downloads/Rcpp.zip",repos=NULL)

But couldn't get it to work, probably because of inexperience with this way of installing packages.

Warning in install.packages :

  'lib = "C:/Users/weldonm.LANCS/Downloads/Rcpp.zip"' is not writable

Error in install.packages : zipfile 'Rcpp' not found

However, now when I try to use sourceCpp on any of my cpp files (which were previously working) I get the message:

Error: 'RcppLdFlags' is not an exported object from 'namespace:Rcpp'

Any help would be greatly appreciated as I was hoping to be able to use the sampling functionality in RcppArmadillo, but now I would be glad to be able to source any of my functions!

Many thanks. Kind regards,

Mat Weldon
Lancaster University
m.weldon at lancaster ac uk
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.r-forge.r-project.org/pipermail/rcpp-devel/attachments/20131031/5557a7ca/attachment.html>

More information about the Rcpp-devel mailing list