[Rcpp-devel] mzR and Rcpp - could not find function "errorOccured"

Dirk Eddelbuettel edd at debian.org
Wed Jun 27 02:04:18 CEST 2012

On 26 June 2012 at 15:55, Dirk Eddelbuettel wrote:
| On 26 June 2012 at 13:42, Davor Cubranic wrote:
| | Doesn't Rcpp 2.11 require 2.15.1, and the computers on which you had problems had 2.15?
| | 
| | Also, you don't say if you tried rebuilding your package, or if you just continued using the same binary. It is possible that since Rcpp API changed, the missing symbol is detected by the dynamic link loader and so aborts loading mzR. (Not sure why it would work on some platforms and not others -- maybe dynamic linking is more tolerant than on others.)
| My thoughts exactly.  
| The variable I commented out within the Evaluator was not (AFAIK) "visible"
| as I try to minimize API changes. So this looks like an unfortunate
| side-effect, but I could of course have created another buglet.
| When I have a moment, I'll try to fetch biobase and mzR to take a look.  We
| certainly want Rcpp to work fine for BioC as well.

FWIW a fresh install worked just fine on Linux (once I added libnetcdf-dev

I think this is "just" a linker issue. If any g++ whizkids here know how to
suppress it going forward, I'd be all ears.


Dirk Eddelbuettel | edd at debian.org | http://dirk.eddelbuettel.com  

More information about the Rcpp-devel mailing list