[Rcpp-commits] r290 - in pkg/inst: . doc
noreply at r-forge.r-project.org
noreply at r-forge.r-project.org
Wed Jan 6 17:44:55 CET 2010
Author: edd
Date: 2010-01-06 17:44:55 +0100 (Wed, 06 Jan 2010)
New Revision: 290
Modified:
pkg/inst/ChangeLog
pkg/inst/doc/Rcpp-unitTests.Rnw
Log:
minor LaTeX tweak to get more stuff onto each page
Modified: pkg/inst/ChangeLog
===================================================================
--- pkg/inst/ChangeLog 2010-01-06 16:40:30 UTC (rev 289)
+++ pkg/inst/ChangeLog 2010-01-06 16:44:55 UTC (rev 290)
@@ -1,52 +1,57 @@
+2010-01-06 Dirk Eddelbuettel <deddelbuettel at wtchi-stat-l1.wolve.com>
+
+ * src/RcppCommon.h: Protect definition of logTxt by #ifndef
+ * inst/doc/Rcpp-unitTests.Rnw: Minor LaTeX tweak
+
2010-01-06 Romain Francois <francoisromain at free.fr>
- * src/Rcpp/wrap.h : wrap can now use initializer lists (available
- on on GCC >= 4.4).
+ * src/Rcpp/wrap.h : wrap can now use initializer lists (available
+ on on GCC >= 4.4).
* src/wrap.cpp: implementation
* int/unitTests/runit.wrap.R: unit tests
- * src/RObject.cpp : make methods RObject::asFoo
+ * src/RObject.cpp : make methods RObject::asFoo
calling Rcpp::as<Foo> to avoid code duplication
2010-01-05 Romain Francois <francoisromain at free.fr>
- * src/Rcpp/GenericVector.h : new class Rcpp::GenericVector
- and an alias Rcpp::List to handle lists (VECSXP), aka generic
+ * src/Rcpp/GenericVector.h : new class Rcpp::GenericVector
+ and an alias Rcpp::List to handle lists (VECSXP), aka generic
vectors
* src/NumericVector.cpp : implementation
* inst/unitTests/runit.NumericVector.R: unit tests
- * src/Rcpp/IntegerVector.h : new class Rcpp::IntegerVector
+ * src/Rcpp/IntegerVector.h : new class Rcpp::IntegerVector
to manage integer vector (INTSXP). IntegerVector can be
- constructed from SEXP of appropriate type, from an int which
- simply allocates a vector that big, or using an
- initialization list (the last is GCC >= 4.4 only).
- Additionally IntegerVector defines begin() and end() so that
+ constructed from SEXP of appropriate type, from an int which
+ simply allocates a vector that big, or using an
+ initialization list (the last is GCC >= 4.4 only).
+ Additionally IntegerVector defines begin() and end() so that
they can be used in STL algorithms
* src/IntegerVector.cpp : implementation
* inst/unitTests/runit.IntegerVector.R: unit tests
- * src/Rcpp/NumericVector.h : same as above, but for numeric
+ * src/Rcpp/NumericVector.h : same as above, but for numeric
vectors (REALSXP)
* src/NumericVector.cpp : implementation
* inst/unitTests/runit.NumericVector.R: unit tests
- * src/Rcpp/RawVector.h : same as above, but for numeric
+ * src/Rcpp/RawVector.h : same as above, but for numeric
vectors (RAWSXP)
* src/RawVector.cpp : implementation
* inst/unitTests/runit.RawVector.R: unit tests
- * src/Rcpp/LogicalVector.h : same as above, but for numeric
+ * src/Rcpp/LogicalVector.h : same as above, but for numeric
vectors (RAWSXP)
* src/LogicalVector.cpp : implementation
* inst/unitTests/runit.LogicalVector.R: unit tests
* src/RcppCommon.h: improve the conditional compiling logic
with macros HAS_VARIADIC_TEMPLATES and HAS_INIT_LISTS instead
- of CXX0X. This ensures the package can be compiled with
+ of CXX0X. This ensures the package can be compiled with
older GCC, with lower functionality
- * src/RcppCommon.{h,cpp}: added a capabilities function that
+ * src/RcppCommon.{h,cpp}: added a capabilities function that
can be used to bring the result of the two above macros to R
* R/RcppLdPaths.R: added unexported function RcppCapabilities
Modified: pkg/inst/doc/Rcpp-unitTests.Rnw
===================================================================
--- pkg/inst/doc/Rcpp-unitTests.Rnw 2010-01-06 16:40:30 UTC (rev 289)
+++ pkg/inst/doc/Rcpp-unitTests.Rnw 2010-01-06 16:44:55 UTC (rev 290)
@@ -1,9 +1,11 @@
-\documentclass[11pt]{article}
+\documentclass[10pt]{article}
%\VignetteIndexEntry{Rcpp-unitTests}
+\usepackage{vmargin}
+\setmargrb{0.75in}{0.75in}{0.75in}{0.75in}
\usepackage[colorlinks]{hyperref}
-\author{Dirk Eddelbuettel, Romain Fran\c{c}ois}
-\title{Rcpp : unit test results}
+\author{Dirk Eddelbuettel \and Romain Fran\c{c}ois}
+\title{Rcpp : Unit testing results}
\begin{document}
\maketitle
More information about the Rcpp-commits
mailing list