[Phylobase-devl] Urgent! problems with installing

Ben Bolker bolker at zoology.ufl.edu
Wed Jul 2 14:26:26 CEST 2008

   I think the warning message is a harmless red herring.

Marguerite Butler wrote:
> Hi Everyone,
> For a brief while, all was fine in Mac binary land. But alas! No more...
> Is anyone else having problems with R 2.7.1 or 2.7.0? I have found that 
> read.nexus from ape does not work, as well as some odd NA-remove 
> behavior in some statistical function.   So I've decided to remain 
> downgraded to R 2.6.2 (patched).

      No problems here with 2.7.0.
   Can you send a read.nexus example for me to try?

> The binaries were available on the r-forge site for a while, but not 
> anymore. 

   It looks (?) like they're there -- I even downloaded the file
and it seems to have the right bits in it, but I can't tell
without trying to install it ...

But my problem is that I can't even install from source. When I
> did R CMD check on the package, I get one warning:
> ====
> * checking if this is a source package ... WARNING
> Subdirectory 'pkg/src' contains object files.
> ====
> I found "phylobase.so" in pkg/src. Is this supposed to be there? It 
> might be the culprit because the error I get when I try to load 
> phylobase is:
>  > require(phylobase)
> Loading required package: phylobase
> Error in dyn.load(file, ...) :
>   unable to load shared library 
> '/Library/Frameworks/R.framework/Resources/library/phylobase/libs/i386/phylobase.so': 
> dlopen(/Library/Frameworks/R.framework/Resources/library/phylobase/libs/i386/phylobase.so, 
> 6): Library not loaded: 
> /Library/Frameworks/R.framework/Versions/2.7/Resources/lib/libR.dylib
>   Referenced from: 
> /Library/Frameworks/R.framework/Resources/library/phylobase/libs/i386/phylobase.so 
>   Reason: image not found
> Which doesn't make a whole lot of sense since I'm installing from source 
> on R 2.6.2.

   It seems it's still looking for a 2.7 library?

> So I went back and removed the "phylobase.so" from the pkg/src directory 
> (the version I got from the svn repository -- revision 192), and tried 
> rebuilding. It passed the check this time, so I installed. But when I 
> try loading, I still get the same error above from my require(phylobase) 
> command??
> Has anyone else had problems?
> I don't think it's entirely a 2.6.2 issue because I don't think it's 
> working for the 2.7.X versions either, otherwise wouldn't there be 
> binaries available?
> I am preparing for the NESCENT course, so this is pretty urgent. Any 
> help would be greatly appreciated.
> Marguerite

    I will do anything I can to help but am a little restricted
since it's working fine for me and I don't have a Mac ...


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 252 bytes
Desc: OpenPGP digital signature
Url : http://lists.r-forge.r-project.org/pipermail/phylobase-devl/attachments/20080702/bb90e2b4/attachment-0001.pgp 

More information about the Phylobase-devl mailing list