[adegenet-forum] DNAbin2genind

Lumley, Lisa Lisa.Lumley at RNCan-NRCan.gc.ca
Mon Jul 18 23:04:54 CEST 2011

Hi Thibault,
I think you are right! I started over, this time installing the package 'graph' first (as per the FAQ) and then Adegenet, and so far so good. Sorry for not noticing this in the first place, and thanks so much for your help.


From: Jombart, Thibaut [mailto:t.jombart at imperial.ac.uk]
Sent: Mon 18/07/2011 5:28 AM
To: Lumley, Lisa; adegenet-forum at r-forge.wu-wien.ac.at
Subject: RE: [adegenet-forum] DNAbin2genind

Hello Lisa,

I think adegenet is not properly installed, or it is an ancestral version. We have tested the package on Linux, MacOSX (leopard I think), and windows 7. It also seem to work on Solaris. Are you using the latest version of R? What is the output when typing:



From: adegenet-forum-bounces at r-forge.wu-wien.ac.at [adegenet-forum-bounces at r-forge.wu-wien.ac.at] on behalf of Lumley, Lisa [Lisa.Lumley at RNCan-NRCan.gc.ca]
Sent: 17 July 2011 23:53
To: adegenet-forum at r-forge.wu-wien.ac.at
Subject: Re: [adegenet-forum] DNAbin2genind

Hi there,

I'm having the same issue with 'import2genind'. I've tried using the new Adegenet, and have tried installing the package using both the command line (asking for all dependencies to be downloaded as well) and the 'point & click' installation method in R. I am wondering if it might be a Windows problem - I'm going to try Linux tomorrow and if I have any epiphanies I'll let you know. Best of luck.


Lisa Lumley

Postdoctoral Fellow
Laurentian Forestry Centre
Canadian Forest Service
Natural Resources Canada
1055 du P.E.P.S., P.O. Box 10380, Stn. Ste. Foy
Quebec, Quebec G1V 4C7

From: adegenet-forum-bounces at r-forge.wu-wien.ac.at [mailto:adegenet-forum-bounces at r-forge.wu-wien.ac.at] On Behalf Of Ilaria Coscia
Sent: July 17, 2011 12:42
To: adegenet-forum at r-forge.wu-wien.ac.at
Subject: [adegenet-forum] DNAbin2genind

I've installed the new Adegenet (1.3) and have been trying to import a DNAbin to Genind with no success since. I keep getting an error message saying that it cannot not find the DNAbin2genind function. Other functions work fine, so I think installation of the package went well. Any thoughts?

Dr Ilaria Coscia
Institute of Biological, Environmental and Rural Sciences (IBERS)
Edward Llwyd Building
Aberystwyth University
Ceredigion SY23 3DA

More information about the adegenet-forum mailing list