[adegenet-forum] Treatment of ploidy by seploc

Aaron.Adamack Aaron.Adamack at canberra.edu.au
Mon Aug 5 09:14:42 CEST 2013

Hi Thibaut,
I'm working on building a function that uses the seploc function on a tetraploid genind object that has a single microsatellite locus with two alleles (e.g. A and B). I'm a bit puzzled by the function's behaviour....

If I have a genind object called "example" and type:
>example at ploidy
The output is:

However if I try:
>seploc(example)[[1]]@ ploidy
I get:

Why would the ploidy change if I separated the loci (just as a note in case it's not obvious, this is just a test case)? I obtained the same result when I duplicated the locus and repeated these steps (checking to see if it might have been due to running seploc on an individual with only one locus). I obtained a similar result when I tried seploc on genind objects with initial ploidies of 3 and 6. In the initial step I got ploidies = 3 or 6 and in the second step I got ploidy = 2.

Thanks for the help,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.r-forge.r-project.org/pipermail/adegenet-forum/attachments/20130805/c92e3c4b/attachment.html>

More information about the adegenet-forum mailing list